入门

安装

安装flatpickr模块

flatpickr主要通过npm安装

Bower 用户: 请使用https://www.npmjs.com/package/bower-npm-resolver

# using npm install
        npm i flatpickr --save

非模块环境

如果出于任何原因,您被限制在非模块环境中(例如,没有打包程序,例如webpack),请不要担心。我建议只是 flatpickr 从中提取最新版本 jsdelivr.

<link rel="stylesheet" href="https://cdn.jsdelivr.net/npm/flatpickr/dist/flatpickr.min.css">
        <script src="https://cdn.jsdelivr.net/npm/flatpickr"></script>

用法

如果使用捆绑器,例如webpack,则需要导入flatpickr。

// commonjs
        const flatpickr = require("flatpickr");
        
        // 如果可用,建议使用es模块,特别是对于typescript
        import flatpickr from "flatpickr";

以下所有都是创建Flatpickr实例的有效方法。

// 如果在框架中使用flatpicker,建议直接传递元素
        flatpickr(element, {});
        
        // 否则,也支持选择器
        flatpickr("#myID", {});
        
        // 创建多个实例
        flatpickr(".anotherSelector");
        

配置是可选的,并传递给对象{}.

jQuery

如果您使用jQuery,则可以使用flatpickr作为插件。

$(".selector").flatpickr(optional_config);